Ekklesia 360 Outage
Incident Report for MonkDev
Resolved
We have restored the functionality to the CMS. Our caching server went down causing our systems to stop requesting traffic. If you have further questions please email support@monkdevelopment.com
Posted Aug 07, 2015 - 16:46 PDT
Investigating
We are currently experiencing an outage of portions of the CMS. Your website should display correctly, and all of your data is secure.

We will post more updates as they become available.
Posted Aug 07, 2015 - 16:07 PDT