Intermittent Form Email Delivery Issue

Incident Report for MonkDev

Resolved

This incident has been resolved.
Posted Aug 17, 2021 - 09:38 PDT

Update

We have implemented a fix for this issue and all emails should be working correctly.
Posted Aug 17, 2021 - 09:37 PDT

Investigating

We are aware of intermittent issues delivering emails from website forms and are working with our email vendor to identify the root cause and resolution. The form submissions are still be tracked in the database and are available in the CMS backend.
Posted Aug 13, 2021 - 17:41 PDT