Sermon Cloud Podcast Feeds
Incident Report for MonkDev
Resolved
We released an update over the weekend to our podcast feeds to fix issues with timeouts when trying to load a feed.
Posted Sep 10, 2018 - 08:49 PDT
Investigating
We are experiencing some issues with podcast feeds in Sermon Cloud.
Posted Sep 05, 2018 - 20:05 PDT
This incident affected: Sermon Cloud.